Jump to content









Photo

Περίεργο πρόβλημα με την 2η NIC σε server.


  • Please log in to reply
10 replies to this topic

#1 fenia

fenia

    IT Pro

  • Members
  • PipPipPip
  • 266 posts

Posted 22 June 2010 - 05:29 PM

Σε 2 ίδιους server (Dell PowerEdge R150) όταν κάνω enable τη 2η κάρτα δικτύου (η πρώτη είναι enabled και configure σωστά) είναι σαν να παγώνει και την πρώτη. Πέφτει αμέσως το δίκτυο. Το ίδιο ακριβώς συμβαίνει και στον 2ο server, άρα φαντάζομαι το να είναι κάποια κάρτα ελλατωματική είναι δύσκολο να έχουν και οι 2 ελλατωματικές κάρτες.

Οι κάρτες δεν ειναι teamed και ότι IP ή subnet βάζω στη 2η NIC, με το που βάζω το καλώδιο πέφτει η σύνδεση. Θέλω να ξεκινήσω το cluster στους Exchange για να χωρίσω τις κάρτες σε public use τη μία και για replication τη 2η και έχω κολλήσει στις κάρτες ... είναι σαν να μη συνεργάζονται μεταξύ τους (όπως εγώ με την ημέρα Τετάρτη χεχεχεχε)... Δοκιμάσαμε επίσης και άλλα καλώδια, με άλλα subnet, στο ίδιο subnet (που "αχρηστεύει όλο το νόημα" αλλά έιπα να δοκιμάσω), βάλαμε τα καλώδια σε άλλα switches, .. τίποτα ...

Έχετε κάποια ιδέα ; :)




MSFT


#2 skok

skok

    Senior IT Pro!

  • Members
  • PipPipPipPipPip
  • 973 posts

Posted 22 June 2010 - 06:38 PM

Γεια σου Φένια,


XFiles : The Truth is Out There [:)]


Αρχικά για να λύσουμε το xfile που αντιμετωπίζεις να ρωτήσω κάποια πράγματα (πιθανον να τα έχεις κάνει ) :


Ας ονομάσουμε Nic 1 την  Card που λειτουργεί και Nic 2 την Card που δεν λειτουργεί.


1. Εχεις ελέγχει για errors σε Driver τις NIC 2 και στους 2 servers στο Device Manager ?


2. Δεν έχεις κάποιο error σε Event Viewer που να σχετίζετε με Nic , Tcp ip ?


3. Εχεις κάνει Disable την Nic 1( αυτή που δουλεύει ) και enabed την Nic 2 και στους 2 servers με την ίδια ip και πάλι αντιμετωπίζεις πρόβλημα με Net ?


4. Έλεγχε το Configuration των Nic , Μetric και Gateway Metric με το παρακάτω command " netsh interface ip show config "


5. Αλλαξε την σειρά των NICs  αν συμβαίνει κάτι και οφείλετε σε Binding NIC Order από "  Control Panel\Network and Internet\Network Connections\ Advanced \ Advanced Settings \ Adapters and Bindings "


 


Spiros Kokolakis (Skok)

B.Sc. Ed. Physics, M.Sc. Information Systems (cand.)
MCT, MCITP, MCSE, MCSA, MCTS, MCP+I, MCP, ITIL v3, CME

"...it seems that the laws of physics present no barrier to reducing the size of computers
until bits are the size of atoms, and quantum behavior holds dominant sway

#3 fenia

fenia

    IT Pro

  • Members
  • PipPipPip
  • 266 posts

Posted 22 June 2010 - 06:57 PM

Γεια σου Φένια,


XFiles : The Truth is Out There [:)]


Αρχικά για να λύσουμε το xfile που αντιμετωπίζεις να ρωτήσω κάποια πράγματα (πιθανον να τα έχεις κάνει ) :


Ας ονομάσουμε Nic 1 την  Card που λειτουργεί και Nic 2 την Card που δεν λειτουργεί.


1. Εχεις ελέγχει για errors σε Driver τις NIC 2 και στους 2 servers στο Device Manager ?


2. Δεν έχεις κάποιο error σε Event Viewer που να σχετίζετε με Nic , Tcp ip ?


3. Εχεις κάνει Disable την Nic 1( αυτή που δουλεύει ) και enabed την Nic 2 και στους 2 servers με την ίδια ip και πάλι αντιμετωπίζεις πρόβλημα με Net ?


4. Έλεγχε το Configuration των Nic , Μetric και Gateway Metric με το παρακάτω command " netsh interface ip show config "


5. Αλλαξε την σειρά των NICs  αν συμβαίνει κάτι και οφείλετε σε Binding NIC Order από "  Control Panel\Network and Internet\Network Connections\ Advanced \ Advanced Settings \ Adapters and Bindings "


 


1-4: Τα είχα κοιτάξει ... τίποτα σε κανένα log...
5 : Επίσης το είχαμε αλλάξει χωρίς να δουλέψει κάτι...

Τελικά κάναμε μια αλχημεία ... κάναμε team μέσω του GUI των καρτών (broadcom) την κάθε κάρτα μόνη της, δικό της team. Δλδ NIC1->TeamPublic και NIC2->TeamRepl ... και έπαιξε για λίγο...σε ξεχωριστά subnet ... τώρα πάλι σταμάτησε ... :S ...

MSFT


#4 skok

skok

    Senior IT Pro!

  • Members
  • PipPipPipPipPip
  • 973 posts

Posted 22 June 2010 - 07:51 PM

Θα σου πρότεινα τα παρακάτω tests ακόμη


1. Uninstall - Install Driver  NIC2.


2. Uninstall Broadcom Advanced Control Suite (BACS) και test των Nic χωρίς Teaming Software


3. Αν λειτουργήσουν χωρίς το BACS . Install BACS ξανά και test again  http://support.dell....nglish/bacs.htm


4.Run Diagnostics apo BACS  http://support.dell....htm#Diagnostics


Spiros Kokolakis (Skok)

B.Sc. Ed. Physics, M.Sc. Information Systems (cand.)
MCT, MCITP, MCSE, MCSA, MCTS, MCP+I, MCP, ITIL v3, CME

"...it seems that the laws of physics present no barrier to reducing the size of computers
until bits are the size of atoms, and quantum behavior holds dominant sway

#5 fenia

fenia

    IT Pro

  • Members
  • PipPipPip
  • 266 posts

Posted 22 June 2010 - 08:57 PM

Ευχαριστώ για την απάντηση skok.

Το έχω δοκιμάσει και αυτό, μιας και αρχικά δεν είχα βάλει καν το BACS...

Πάντως τώρα δουλεύει (με την αλχημεία που περιέγραψα πριν..) ...

Απλά έκανε reset το BACS όλα τα FW rules (και τα exceptions που βάζει ο Exchange στην εγκατάσταση) αλλά διορθώθηκε και αυτό...

Τώρα γιατί οι κάρτες δεν δουλεύουν όπως θα έπρεπε κανονικά ... δεν ξέρω ... :(


MSFT


#6 skok

skok

    Senior IT Pro!

  • Members
  • PipPipPipPipPip
  • 973 posts

Posted 22 June 2010 - 10:52 PM

Προσπάθησα να σε βοηθήσω [;)]


- Αν είχα το πρόβλημα αυτό σε server θα έβλεπα το Firmware Version των 2 NICs και θα προχωρούσα σε  upgrade σε latest version.


- Επίσης θα προχωρούσα σε Disabled του Large Send Offload στις NICs (Broadcom NetXtreme II GigE Properties, click  Advanced tab,IPv4 Large Send Offload setting, select Disabled ) 


 οπως αναφέρετε στα άρθρα :


1. http://social.techne...3b-a695f382e01a


2. http://autoexec.gr/b...is-enabled.aspx  


- Και Disabled το Power Management στις NICs
Από  Device Manager - Network Adapters - Properties - Power Management - Uncheck Option "Allow the computer to turn off this device to save power " και για τις 2 Nics


Αν βρώ κάποιο άλλο article για  Windows 2008 - Broadcom θα σε ενημερώσω.


 


Spiros Kokolakis (Skok)

B.Sc. Ed. Physics, M.Sc. Information Systems (cand.)
MCT, MCITP, MCSE, MCSA, MCTS, MCP+I, MCP, ITIL v3, CME

"...it seems that the laws of physics present no barrier to reducing the size of computers
until bits are the size of atoms, and quantum behavior holds dominant sway

#7 Akladakis

Akladakis

    Πολύ παλιός

  • Administrators
  • 2,679 posts

Posted 24 June 2010 - 04:18 AM

Φενια, η αλχημεία αυτή είναι ...τραγική απο πλευράς συμβιβασμού που κάνεις για να παίξει. Εφιαλτικό by pass. Προφανώς και θα το έκανα αν πιεζόμουν φρικτά για να παίξει το cluster. Αλλά στο πρώτο πρόβλημα ξέρεις τι θα πει ο ...κατασκευαστής του λογισμικού. Unsupported, tragic, ftou kaka.


Πραγματικά ισως πρέπει να δεις λίγο το θέμα των drivers.


Τι λέει το exchange team? Τι λένε οι ccnaδες?


Προφανως ψηφίζω 100% το disable κάθε advance feature της κάρτας που περιλαμβάνει την λέξη offload.


AMCT)
Nasos Kladakis,

#8 George Andritsos

George Andritsos

    IT Pro

  • Members
  • PipPipPip
  • 422 posts
  • LocationThessaloniki

Posted 24 June 2010 - 05:08 AM

Φένια απάντησε μου λίγο σε κάτι:

Αν κάνεις απλα enable την 2η nic χωρίς να βάλεις καλώδιο πως συμπεριφέρεται ?

???????? ??


#9 fenia

fenia

    IT Pro

  • Members
  • PipPipPip
  • 266 posts

Posted 24 June 2010 - 01:24 PM

Νάσο ήταν προσωρινό bypass μέχρι να βρούμε τι φταίει γιατί  πιέζει φρικτά όπως είπες ο χρόνος.  Φυσικά και δεν είναι λύση, ούτε θα μείνει έτσι...  έχει σταλθεί log στη Dell αναμένουμε απάντηση [:^)]

MSFT


#10 skok

skok

    Senior IT Pro!

  • Members
  • PipPipPipPipPip
  • 973 posts

Posted 24 June 2010 - 05:25 PM

Φένια Γεια,


Προφανώς με όλα αυτά τα tests , disabled ολα τα "offload" που λέει και ο Νάσος και upgrade driver /firmware που έκανεις στις NICs και δεν λειτούργησαν αποδεικνύεται ότι είναι πρόβλημα HW/NIC/Motherboard ισως.


Εφόσον συμβαίνει όμως σε 2 servers ( περίεργο αλλα μου έχει συμβεί με άλλο part και άλλο vendor ) μιλάμε για ελλατωματική παρτίδα αν τους έχεις αγοράσει μαζί .


Αν οι servers είναι σε εγγύηση ή έχεις κάποιο συμβόλαιο συντήρησης και σε πιέζει ο χρόνος με deadlines σε project ζήτα άμεσα αντικατάσταση motherboad/NIC ή server και μην μπαίνεις σε διαδικασία support ( παρε log - δώσε log - εχετε κάνει upgrade το driver/firmware ? εχετε τρεξει diagnostics από BACS ? και τις γνωστές ερωτήσεις ) γιατί είναι ποιο χρονοβόρα και στο τέλος θα καταλήξει και πάλι να σου πούνε για αντικατάσταση motherboard/nic/server.


 


Spiros Kokolakis (Skok)

B.Sc. Ed. Physics, M.Sc. Information Systems (cand.)
MCT, MCITP, MCSE, MCSA, MCTS, MCP+I, MCP, ITIL v3, CME

"...it seems that the laws of physics present no barrier to reducing the size of computers
until bits are the size of atoms, and quantum behavior holds dominant sway

#11 fenia

fenia

    IT Pro

  • Members
  • PipPipPip
  • 266 posts

Posted 29 June 2010 - 04:47 PM

Για την ιστορία να σας ενημερώσω ότι απάντησε η Dell και έχουν πρόβλημα ή οι κάρτες ή η motherboard - δεν ξέρουν τί από τα 2 φταίει και ζήτησαν τους server πίσω ...

MSFT





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users