Jump to content









Photo

System locale / sysprep / sccm deployment


  • Please log in to reply
13 replies to this topic

#1 lekanopedio

lekanopedio

    Junior IT

  • Members
  • PipPip
  • 78 posts

Posted 30 November 2010 - 09:24 PM

Έχω κάνει capture customized image από WDS με το system locale Greek.Την έχω κάνει import στον SCCM και με το αντίστοιχο Task Sequence την κάνω deploy στους clients.Mετά το deploy οι clients έχουν English system locale, έτσι ώστε νάναγκαστώ να προσθέσω ένα command line στον Task Sequence EDITOR του τύπου "rundll32 shell32, Control_RunDLL intl.cpl,,/f:"\\scsrv\SoftwareDistributionSource\Unattend XMLs\X86\regional and locale settings\locale.txt" , όπου locale.txt είναι :














Να πω ότι η customized image που έχω δεν μπορεί να γίνει import στο WSIM, δεν ξέρω γιατί, έτσι ώστε να φτιάξω ένα answer file .
Καμιά ιδέα κανείς έτσι ώστε από το Task Sequence να έχω το σωστό system locale.
Eπίσης αν την ίδια εικόνα την κάνω deploy μέσω του WDS το System Locale είναι σωστό, greek.
Giannis Priovolos
MCTS 70-640, 70-642, 70-643
MCITP 70-646
MCTS 70-401

#2 GSimos

GSimos

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,141 posts
  • LocationThessaloniki, Greece

Posted 01 December 2010 - 03:11 PM

Γιάννη,


Στείλε εδώ το αρχείο από το Task Sequence.


Επίσης γίνε λίγο πιο συγκεκριμένος σχετικά με το Locale, θέλεις το ελληνικό πληκτρολόγιο να είναι το Default? θέλεις να υπάρχει αγγλικό και ελληνικό πληκτρολόγιο και να είναι Default το αγγλικό? ή σου αλλάζει το Region από Greek σε κάτι άλλο;


George Simos

Degree Computer Science

MCT, MCITP Enterprise Admin, MCTS: Hyper-V, SCVMM, SCCM

Microsoft Former MVP SCCM

Auditor: ISO 27001, ISO 9001

Security Consultant


#3 lekanopedio

lekanopedio

    Junior IT

  • Members
  • PipPip
  • 78 posts

Posted 01 December 2010 - 03:35 PM

Γεια σου Γιώργο,
καταρχάς να πω ότι η εικόνα έχει και το Αγγλικό και το Ελληνικό πακέτο γλωσσών installed.Για ότι αφορά το region δεν υπάρχει πρόβλημα ούτε στο Format(greek). ούτε στο Location((greek), ούτε στα keyboards and Languages μιας και έχει και τα δύο πακέτα γλωσσών εγκατεστημένα(input English).Το πρόβλημα είναι στο Current Language for non-Unicode programs(βλέπε SAP) που παραμένει English.
To αρχειάκι που έχω φτιάξει με την εντολή που είχα στείλει στο προηγούμενο post απλώς αλλάζει το system locale σε el-gr.To θέμα μου είναι, αν και έχει μπει σαν command line στον Task Sequence Editor, ότι είναι πολύ manual κατάσταση μεν επιτυχημένη δε.
Μέχρι να φτάσω στο σημείο να ξεκινώ από ένα καθαρό install.wim, να φτιάχνω answer files(SIM) που θα λύνουν τα παραπάνω προβλήματα, πρέπει να συμβιβαστώ με την customized εικόνα που έχω φτιάξει.

***Γιώργο επίσης αν έχουμε κάποιον guide για deploy Οffice 2010 μέσω MDT 2010, όχι στην όλη διαδικασία πού είναι απλή, αλλά στο κομμάτι του import των updates του Office και ιδίως του Language Pack & Proof tools.
Giannis Priovolos
MCTS 70-640, 70-642, 70-643
MCITP 70-646
MCTS 70-401

#4 GSimos

GSimos

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,141 posts
  • LocationThessaloniki, Greece

Posted 01 December 2010 - 05:43 PM

Γιάννη, θα σου απαντήσω σχετικά με το πρώτο σύντομα, απλά στείλε το αρχείο του Task Sequence, επίσης πες μου αν είναι ConfigMgr TS ή MDT TS (έχει διαφορά), υποθέτω ότι έχεις ενσωματώσει το MDT 2010 στον ConfigMgr σωστά;


Για το Office το πιο εύκολο που έχεις να κάνεις είναι να κατεβάσεις την ελληνική έκδοση και με το Setup Manager να φτιάξεις το αρχείο που χρησιμοποιεί η εγκατάσταση για να περνά τις παραμετροποιήσεις στη Setup Engine.


Δεσμεύομαι να γράψω έναν οδηγό στο Blog μου που θα έχει και το Slipstreaming Service Packs για Office 2007 (γιατί χρησιμοποιείται πολύ ακόμη).


 


George Simos

Degree Computer Science

MCT, MCITP Enterprise Admin, MCTS: Hyper-V, SCVMM, SCCM

Microsoft Former MVP SCCM

Auditor: ISO 27001, ISO 9001

Security Consultant


#5 lekanopedio

lekanopedio

    Junior IT

  • Members
  • PipPip
  • 78 posts

Posted 01 December 2010 - 06:18 PM

MDT Task Sequence Editor MDT 2010 sp1 έχω. Με μπέρδεψες όμως, ποιο αρχείο Task sequence θέλεις? Αυτό που χρησιμοποιώ στο command line η κάποιο log η ini του TS?
Giannis Priovolos
MCTS 70-640, 70-642, 70-643
MCITP 70-646
MCTS 70-401

#6 GSimos

GSimos

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,141 posts
  • LocationThessaloniki, Greece

Posted 01 December 2010 - 07:28 PM

Μια χαρά είναι αυτό που έστειλες (απλά καλό θα είναι να το σώζεις με extension .xml), το κοιτάζω και σου απαντάω.

George Simos

Degree Computer Science

MCT, MCITP Enterprise Admin, MCTS: Hyper-V, SCVMM, SCCM

Microsoft Former MVP SCCM

Auditor: ISO 27001, ISO 9001

Security Consultant


#7 GSimos

GSimos

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,141 posts
  • LocationThessaloniki, Greece

Posted 01 December 2010 - 07:44 PM

Λοιπόν θα κάνω υποθέσεις και θα μου πεις τι ισχύει:


1) Έκανες την εγκατάσταση των 7 και την παραμετροποίησες με κάποιο τοπικό ADMINISTRATIVE account?


2) Ακολούθησες τις οδηγίες εδώ: How to customize the default local user profile when you prepare an image of Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2 πριν κλείσεις το image σου (πιθανότατα όχι)


Αν είχες κάνει τα παραπάνω θα μπορούσαμε να το σώσουμε πιο εύκολα το πρόβλημα σου γιατί θα είχες ήδη ένα answer file προς χρήση.


Θα χρειαστώ λίγο χρόνο όμως για να βρώ ένα workaround και να σου απαντήσω με σιγουριά.


George Simos

Degree Computer Science

MCT, MCITP Enterprise Admin, MCTS: Hyper-V, SCVMM, SCCM

Microsoft Former MVP SCCM

Auditor: ISO 27001, ISO 9001

Security Consultant


#8 lekanopedio

lekanopedio

    Junior IT

  • Members
  • PipPip
  • 78 posts

Posted 01 December 2010 - 08:07 PM

To μετέτρεψα σε txt γιατί το xml χτύπαγε στο upload.
Πράγματι δεν ακολούθησα το 2ο κομμάτι που μου γράφεις. Το μελετώ και τα ξαναλέμε. Ευχαριστώ πολύ Γιώργο
Giannis Priovolos
MCTS 70-640, 70-642, 70-643
MCITP 70-646
MCTS 70-401

#9 GSimos

GSimos

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,141 posts
  • LocationThessaloniki, Greece

Posted 01 December 2010 - 08:11 PM

Γιάννη,


Το 1ο που σε ρωτάω το έκανες η χρησιμοποίησες Domain Admin Account; γιατί πάλι θα έχεις θέμα όταν προσπαθήσεις να κάνεις την αντιγραφή στο Default User Profile.


Ξέχασα να σου πω ότι το Task Sequnce σου είναι του Configuration Manager όχι του MDT, μου φαίνεται ότι πρέπει να σας μαζέψω για σεμινάρια βαριά [:D]


George Simos

Degree Computer Science

MCT, MCITP Enterprise Admin, MCTS: Hyper-V, SCVMM, SCCM

Microsoft Former MVP SCCM

Auditor: ISO 27001, ISO 9001

Security Consultant


#10 GSimos

GSimos

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,141 posts
  • LocationThessaloniki, Greece

Posted 01 December 2010 - 08:21 PM

Να πω ότι η customized image που έχω δεν μπορεί να γίνει import στο WSIM, δεν ξέρω γιατί, έτσι ώστε να φτιάξω ένα answer file . Καμιά ιδέα κανείς έτσι ώστε από το Task Sequence να έχω το σωστό system locale. Eπίσης αν την ίδια εικόνα την κάνω deploy μέσω του WDS το System Locale είναι σωστό, greek.



  1. Εδώ τι σφάλμα σου εμφανίζει;

  2. Μήπως είναι θέμα χώρου στο drive που βρίσκεται το wim;

  3. Το ανοίγεις τοπικά ή από κάποιο unc path στο δίκτυο;

  4. Το WSIM το εκτελείς ως Administrator;

George Simos

Degree Computer Science

MCT, MCITP Enterprise Admin, MCTS: Hyper-V, SCVMM, SCCM

Microsoft Former MVP SCCM

Auditor: ISO 27001, ISO 9001

Security Consultant


#11 lekanopedio

lekanopedio

    Junior IT

  • Members
  • PipPip
  • 78 posts

Posted 01 December 2010 - 09:37 PM

1)Xρησιμοποίησα το Local Administrator account
2)To task sequence πράγματι είναι του Configmgr, αυτό δεν σημαίνει ότι δεν έχω και create microsoft Deployment Task Sequence.Απλώς με τις τόσες δοκιμές ξέχασα ότι δοκίμασα και το απλό CM Task sequence ..μη βαράς...αμέσως σεμινάρια!

3)Το σφάλμα είναι στα attached
4)Χώρο έχουμε plenty
5)Το ανοίγω τοπικά
6)To WSIM Σαν Administrator
Giannis Priovolos
MCTS 70-640, 70-642, 70-643
MCITP 70-646
MCTS 70-401

#12 GSimos

GSimos

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,141 posts
  • LocationThessaloniki, Greece

Posted 01 December 2010 - 10:08 PM

Λοιπόν, ερωτήσεις ξανά, για το WSIM όμως, το λειτουργικό στο σύστημα που προσπαθείς να ανοίξεις το WIM μέσω του WSIM τι αρχιτεκτονικής είναι; 32 ή 64 bit;


Το λειτουργικό του Image τι αρχιτεκτονικής είναι;


Γιατί δεν μπορείς να ανοίξεις Windows 7 (πρόσεξε μόνο Windows 7) 32 bit WIM σε 64 bit λειτουργικό σύστημα και τούμπαλιν με την αντίστοιχη βέβαια έκδοση του WSIM & WAIK.


Ίσως αυτή να είναι η λύση για το WSIM, σειρά σου τώρα [:)]


George Simos

Degree Computer Science

MCT, MCITP Enterprise Admin, MCTS: Hyper-V, SCVMM, SCCM

Microsoft Former MVP SCCM

Auditor: ISO 27001, ISO 9001

Security Consultant


#13 lekanopedio

lekanopedio

    Junior IT

  • Members
  • PipPip
  • 78 posts

Posted 01 December 2010 - 10:51 PM

Για ότι αφορα το WSIM έπεσες διάνα!!!αυτό ήταν το θέμα μου και θα με βασάνιζε για καιρό αν δεν μου το αποκάλυπτες.Εύγε Γιώργο και ευχαριστώ πολύ, η βοήθεια σου ήταν πολύτιμη
Giannis Priovolos
MCTS 70-640, 70-642, 70-643
MCITP 70-646
MCTS 70-401

#14 GSimos

GSimos

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,141 posts
  • LocationThessaloniki, Greece

Posted 01 December 2010 - 11:41 PM

Ως συνήθως στη διάθεση σας!


Χαίρομαι που το ξεκαθαρίσαμε και αυτό, χρωστάω και ένα post για το Deployment του Flash Player που είδαμε Offline, έχουν μπει πολλά στο Blog Pipeline όμως τελευταία και πρέπει να βάλω μια σειρά.... Μετά το Troubleshooting του ConfigMgr μάλλον....


George Simos

Degree Computer Science

MCT, MCITP Enterprise Admin, MCTS: Hyper-V, SCVMM, SCCM

Microsoft Former MVP SCCM

Auditor: ISO 27001, ISO 9001

Security Consultant





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users