Jump to content









Photo

metasploit on os x ... no minitest-4.7.5 and no Gemfile or .bundle/ directory


  • Please log in to reply
7 replies to this topic

#1 Blackman

Blackman

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,962 posts
  • LocationIn a b-boy cypher...

Posted 14 October 2015 - 10:27 PM

Blackmans-MacBook-Pro:/ blackman$ msfconsole
Could not find minitest-4.7.5 in any of the sources
Run `bundle install` to install missing gems.
Blackmans-MacBook-Pro:/ blackman$ bundle install
Could not locate Gemfile or .bundle/ directory

κάτι έκανα brick...
όλα έπαιζαν σωστά μεχρί που έκανα αυτό
 

sudo chmod o+r /Library/Ruby/Gems/2.0.0/gems/robots-0.10.1/lib/robots.rb

το οποίο με ταλαιπώρησε γιατί δεν έβρισκε κάν το robots*

αλλά το έλυσα.
μετά πήγα να τρέξω το msfconsole και έγινε το παραπάνω.

το directory υπάρχει. πιστεύω ότι κάτι έχει παίξει με τα paths!

το κεφάλι μου έχει γίνει καζάνι! οπότε...

any ideas;;;;;

Attached Files


BSc in Business Information Systems,
MSc in Information Technology Management,
MCP, MCSA 2003, MCSA 2008, MCSA 2008:Virtualization
IT Manager @ V-Group

#2 Nikos Kastanas

Nikos Kastanas

    Skilled IT Pro

  • Members
  • PipPipPipPip
  • 760 posts

Posted 15 October 2015 - 10:12 AM

Εισαι σιγουρος για το path? μηπως ειναι αλλη ruby version ?

 

 

ΝΚ


twitter_logo.png


#3 costasppc

costasppc

    Senior IT Pro!

  • Members
  • PipPipPipPipPip
  • 924 posts

Posted 15 October 2015 - 02:03 PM

Κάτι γίνεται με τα paths σου.

 

Για δες αυτό: rvm gemset use metasploit-framework

 

Κ


ACSA, ACT, ACTS, ACTC 10.7, 10.6
?CTS: WS 2008 R2, Server Virtualization
6425, 6426, 6419 done...

#4 kavasilop

kavasilop

    Junior IT

  • Members
  • PipPip
  • 21 posts

Posted 16 October 2015 - 12:07 AM

Dokimase na treksis to msfconsole mesa sto path pou exeis to msf....



#5 Blackman

Blackman

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,962 posts
  • LocationIn a b-boy cypher...

Posted 16 October 2015 - 02:26 PM

ευχαριστώ παίδες...

ήμουν σίγουρος ότι είναι κάτι με τα paths...
από εκεί τσεκάρωντας μεσα από το irb
έλυσα και το θέμα του robots

αλλά θα τα δοκιμάσω και θα το δω!


BSc in Business Information Systems,
MSc in Information Technology Management,
MCP, MCSA 2003, MCSA 2008, MCSA 2008:Virtualization
IT Manager @ V-Group

#6 Blackman

Blackman

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,962 posts
  • LocationIn a b-boy cypher...

Posted 17 October 2015 - 05:13 PM

Blackmans-MacBook-Pro:~ blackman$ rvm gemset use metasploit-framework
Warning! PATH is not properly set up, '/Users/blackman/.rvm/gems/ruby-2.1.7/bin' is not available,
usually this is caused by shell initialization files - check them for 'PATH=...' entries,
it might also help to re-add RVM to your dotfiles: 'rvm get stable --auto-dotfiles',
to fix temporarily in this shell session run: 'rvm use ruby-2.1.7'.
Gemset 'metasploit-framework' does not exist, 'rvm ruby-2.1.7 do rvm gemset create metasploit-framework' first, or append '--create'.

-----------

Blackmans-MacBook-Pro:~ blackman$ rvm use ruby-2.1.7
Using /Users/blackman/.rvm/gems/ruby-2.1.7
Blackmans-MacBook-Pro:~ blackman$ msfconsole
/Users/blackman/.rvm/rubies/ruby-2.1.7/lib/ruby/site_ruby/2.1.0/rubygems/dependency.rb:315:in `to_specs': Could not find 'metasploit-framework' (>= 0) among 95 total gem(s) (Gem::LoadError)
Checked in 'GEM_PATH=/Users/blackman/.rvm/gems/ruby-2.1.7:/Users/blackman/.rvm/gems/ruby-2.1.7@global', execute `gem env` for more information
    from /Users/blackman/.rvm/rubies/ruby-2.1.7/lib/ruby/site_ruby/2.1.0/rubygems/dependency.rb:324:in `to_spec'
    from /Users/blackman/.rvm/rubies/ruby-2.1.7/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:64:in `gem'
    from /Users/blackman/.rvm/gems/ruby-2.1.7/bin/msfconsole:22:in `<main>'
    from /Users/blackman/.rvm/gems/ruby-2.1.7/bin/ruby_executable_hooks:15:in `eval'
    from /Users/blackman/.rvm/gems/ruby-2.1.7/bin/ruby_executable_hooks:15:in `<main>'



γαμώ τα paths μου...


BSc in Business Information Systems,
MSc in Information Technology Management,
MCP, MCSA 2003, MCSA 2008, MCSA 2008:Virtualization
IT Manager @ V-Group

#7 Blackman

Blackman

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,962 posts
  • LocationIn a b-boy cypher...

Posted 26 October 2015 - 11:14 AM

λέω να τα κάνω όλα από την αρχή! λέτε να βοηθήσει;;;

ή πρέπει να ασχοληθώ συγκεκριμένα με τα paths!

το μοναδικό που έκανα με Paths πάντως ήταν να τρέξω το irb για να φτιάξω το θέμα με το robots.rb αλλά δεν άλλαξα κάτι!


BSc in Business Information Systems,
MSc in Information Technology Management,
MCP, MCSA 2003, MCSA 2008, MCSA 2008:Virtualization
IT Manager @ V-Group

#8 Blackman

Blackman

    Enterprise Admin!

  • Members
  • PipPipPipPipPipPip
  • 1,962 posts
  • LocationIn a b-boy cypher...

Posted 29 October 2015 - 04:05 PM

μέσα από τον κατάλογο του metasploit και εφόσον έτρεξα

gem install bundler
bundle install

έπαιξε...

αλλά μου τρέχει ΜΟΝΟ μέσα από τον κατάλογο του metasploit

θυμίστε μου πως δηλώνω το path για να είναι global;

 


BSc in Business Information Systems,
MSc in Information Technology Management,
MCP, MCSA 2003, MCSA 2008, MCSA 2008:Virtualization
IT Manager @ V-Group




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users