Jump to content
Sign in to follow this  
v_pasch

Outgoing Email σε Sharepoint Server 2007

Recommended Posts

Καλημέρα, έχουμε στημένο έναν Sharepoint Server 2007 σε Windows Server 2008 R2 και θέλουμε να μπορούμε να στέλνει ο Sharepoint αυτόματα email όταν δημιουργούμε tasks σε κάποιον. Ο SMTP είναι installed & started και πήγα στο Web Application Outgoing E-Mail Settings και ρύθμισα τα settings αλλά μου βγάζει Unknown Error. Έχω δηλώσει Outbound SMTP server και τα emails και έχω πάει στον IIS και στο smtp έχω δηλώσει και εκεί τα ίδια.

 

Μήπως απαιτείται exchange?

Share this post


Link to post
Share on other sites

Μετά ενεργοποιείς το Alert στο σημείο που θέλεις. Αν πας σε μια λίστα για παράδειγμα, έχει ένα Alert Me ή κάτι τέτοιο δεν το θυμάμαι απ'εξω.

Share this post


Link to post
Share on other sites

Καλημέρα, έχουμε στημένο έναν Sharepoint Server 2007 σε Windows Server 2008 R2 και θέλουμε να μπορούμε να στέλνει ο Sharepoint αυτόματα email όταν δημιουργούμε tasks σε κάποιον. Ο SMTP είναι installed & started και πήγα στο Web Application Outgoing E-Mail Settings και ρύθμισα τα settings αλλά μου βγάζει Unknown Error. Έχω δηλώσει Outbound SMTP server και τα emails και έχω πάει στον IIS και στο smtp έχω δηλώσει και εκεί τα ίδια. Μήπως απαιτείται exchange?

Αν θυμάμαι καλά δεν μπορείς να βάλεις credentials στο λογαριασμό του SMTP service από μέσα από το OSS 2007. Αυτό που συνήθως κάνουμε, είναι να βάζουμε τον SharePoint σε να βλέπει ένα τοπικό SMTP service που δεν απαιτεί credentials για σύνδεση και στην συνέχεια στον Exchange Server μας επιτρέπουμε σε αυτό το service να είναι Relay Server. Έτσι έχουμε ειδοποιήσεις μέσω e-mail μέσα και έξω από το domain μας.

Αν κάνω λάθος, ο Καναβός θα με κατακεραυνώσει, αν όχι θα πει ότι έχω δίκιο... [:)]

 

George J.

Share this post


Link to post
Share on other sites

Δεν έχουμε exchange server και το Email Hosting είναι στο gmail.

Ο SMTP στον IIS είναι installed & started και πήγα στο SharePoint Central Administration -> Operations -> Topology and Services ->Outgoing Email Settings. Εκεί δήλωσα smtp.gmail.com και τα email της εταιρίας.

 

Όταν πάω να κάνω σε κάποιον Alert me και βάλω το όνομα του και το στέλνω δε μου βγάζει κάποιο λάθος.

 

Ακολούθησα και αυτό τον οδηγό για να συνδέεται με το gmail.

 

http://fmuntean.wordpress.com/2008/10/26/how-to-configure-iis-smtp-server-to-forward-emails-using-a-gmail-account/

 

Αλλά ακόμα τίποτα. Άλλαξα και στο Outgoing Email Settings το smtp server και έβαλα το όνομα του server που έχει το smtp service που είναι ο ίδιος ο Sharepoint.

Νομίζω παίζει και χωρίς Exchange

Share this post


Link to post
Share on other sites

Αν υποθέσουμε ότι παίζει η διαδικασία που περιγράφει το blog - δεν έχω λόγο να την αμφισβητήσω - θα πρέπει να settαρεις τον SharePoint να βλέπει τον τοπικό SMTP και όχι το Gmail...

Και προσοχή τα credential για το GMail SMTP πρέπει να είναι αυτά του email λογαριασμού που χρησιμοποιεί ο SharePoint για να στείλει ειδοποιήσεις...

 

George J.

Share this post


Link to post
Share on other sites
Αν υποθέσουμε ότι παίζει η διαδικασία που περιγράφει το blog - δεν έχω λόγο να την αμφισβητήσω - θα πρέπει να settαρεις τον SharePoint να βλέπει τον τοπικό SMTP και όχι το Gmail...

Και προσοχή τα credential για το GMail SMTP πρέπει να είναι αυτά του email λογαριασμού που χρησιμοποιεί ο SharePoint για να στείλει ειδοποιήσεις...

Νομίζω ότι κάπου έχουμε μπερδευτεί για να ξεκαθαρίσω:

Καταρχήν δεν χρειάζεται και καλά Exchange - έχω settaρει SharePoint με MailEnable και παίζει άψογα.

Ο SharePoint πρέπει να βλέπει τοπικό SMTP - δεν υπάρχει επιλογή σε αυτό.

Αν settarεις τον τοπικό SMTP με τον τρόπο που περιγράφει στο blog post που αναφέρεις, θα μπορέσεις να κάνεις forward το GMail χωρίς πρόβλημα - μπορείς να τεστάρεις την σύνδεση αυτή με ένα Outlook Express αν χρησιμοποιήσεις τον λογαριασμό που έχεις ορίσει στον SharePoint να στείλνει ειδοποιήσεις, και σαν SMTP το τοπικό service. Δεν απαιτείται να settarεις και το POP3 για αυτή τη δοκιμή.

Βασικό, είναι ότι ο λογαριασμός που βάζεις για το GMail να είναι ο ίδιος που είναι στο From: των μηνυμάτων του SharePoint.

 

George J.

Share this post


Link to post
Share on other sites

Τελικά ήθελε το write permission γτου IIS User στον pickup folder για να μπορέσει να στείλει.

Τώρα στέλνει ο smtp του sharepoint, οπότε θεωρώ ότι αν πω στο smtp να έχει smart host τον smtp.gmail.com και να δώσω τα credentials του user που θα στέλνει το alert με TLS και δώσω και το 587 Port ότι θα στείλει κανονικά μέσω gmail σωστά?

 

Share this post


Link to post
Share on other sites

Έπαιξε κανονικά.

Οπότε στον Queue & pickup folder βάζουμε το write permission του IIS User για να μπορέσει να στείλει.

Ευχαριστώ

Share this post


Link to post
Share on other sites

Έπαιξε κανονικά. Οπότε στον Queue & pickup folder βάζουμε το write permission του IIS User για να μπορέσει να στείλει. Ευχαριστώ

Αυτό δεν θα έπρεπε να συμβαίνει - μήπως έχουν πειραχτεί τα permissions στο X:\inetpub για άλλους λόγους, όπως για την ασφάλεια του web server;

 

George J.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...