Jump to content
Sign in to follow this  
nextp

SQL Server 2008 R2 express with advanced services issues

Recommended Posts

Καλησπερα 

 Εχω στημενο εναν SQL Server 2008 R2 express with advanced services.
Εχω κανει ολες τις απαριατητες ρυθμισεις για να τον βλεπω remotely απο το Internet (sql browser / network protocols / firewall shutdown / port 
forwarding) και παρολα αυτα δεν τον βλεπω με management studio.
Ειναι σε default instance αρα ακουει 1433 και αυτο που δεν παει καλα ειναι οτι ενω στο configuration tool εχω σε ολες τις Ip - enable και πορτα την 1433
με netstat -ano δεν φαινεται να ακουει στην ipv4 του μηχανηματος - ενω ειναι και αυτη enabled.

Υπαρχει κατι αλλο που πρεπει να δω?
 

Share this post


Link to post
Share on other sites

Ο Express δεν είναι στο default instance! Και δεν ακούει στην 1433! Πάντα πάει σε named instance (SQLEXPRESS).

Άρα πήγαινε με ip\SQLEXPRESS

Share this post


Link to post
Share on other sites

Καταρχην ευχαριστω για την αμεση απαντηση.

Ξερω οτι default o express παιζει σε named instance.Κατα την εγκαταστση ομως εγω ζητησα να ειναι σε default.

Με το netstat ακουει στην 0.0.0.0:1433 /127.0.0.1:1433 στην ipv6 αλλα οχι στην ipv4 192.168.1.14:1433  ενω ειναι ενεργη στο configuration.
Μηπως υπαρχει κατι στην registry που θα μπορουσα να δω?

Share this post


Link to post
Share on other sites

Στο τελευταίο Tab των Ip του configuration manager κάτω , τι γράφει?

Βασικά δεν είναι σωστό να έχεις τον SQL στο internet έτσι και αλλιώς πόσο μάλλον στην 1433.

Share this post


Link to post
Share on other sites
Καλησπερα 

 Εχω στημενο εναν SQL Server 2008 R2 express with advanced services.
Εχω κανει ολες τις απαριατητες ρυθμισεις για να τον βλεπω remotely απο το Internet (sql browser / network protocols / firewall shutdown / port 
forwarding) και παρολα αυτα δεν τον βλεπω με management studio.
Ειναι σε default instance αρα ακουει 1433 και αυτο που δεν παει καλα ειναι οτι ενω στο configuration tool εχω σε ολες τις Ip - enable και πορτα την 1433
με netstat -ano δεν φαινεται να ακουει στην ipv4 του μηχανηματος - ενω ειναι και αυτη enabled.

Υπαρχει κατι αλλο που πρεπει να δω?
 

 

Έχεις κάνει τις απαραίτητες ρυθμίσεις όπως: "Firewall Shutdown"!!!!!!! και Port Forwarding για να το βλέπεις από το Internet!

Οπωσδήποτε ενεργοποίησε το Firewall, δεύτερον ακόμα και στο εσωτερικό δίκτυο μη χρησιμοποιείς τη Default πόρτα 1433 το ίδιο και στο PAT (Port Address Translation) που κάνεις στο router σου.

 

Share this post


Link to post
Share on other sites

Ευχαριστω και παλι ολους.

Μεσα στο management studio εχω enabled το αccept incoming connections και επισης σε 
ολα τα ip settings που αναφερουν ports υπαρχει η 1433-active και enabled. 

Το θεμα ειναι οτι θελω να παιξω μια απομακρυσμενη application - βεβαια να πω την αληθεια  και εγω ειμαι υπερ του pat translation η ακομη και του internal service port change σε συνδυασμο με pat/nat αλλα δεν θα ηθελα να ζωρισω τον developer με custom connection strings.(Λαθος τακτικη ασφαλειας.... πολυ σωστη η παρατηρηση..)

Αν και νομιζω οτι το προβλημα ειναι στο tcp stack των windows - θα δω και αυτο με την επανενεργοποιηση του firewall Γιώργο.

Σημερα θα αντιμετωπισω το ζητημα και θα ενημερωσω.

Και παλι ευχαριστω.

Share this post


Link to post
Share on other sites
Απο την αρχή του υπόθεσης πίστευα οτι ήταν πρόβλημα των windows(registry related / service related...or something)


Αγαπητε skok αυτο που φοβόμουν ήταν οτι κατι όντος συνέβαινε με to stack των windows διοτι το μηχανημα επαιζε κανονικά προς τα έξω αλλα δεν άκουγε πρός τα μέσα - τίποτε απολύτως.Ουτε Ping ούτε sql management studio - ουτε καν shared resources.
Το αστειο ήταν οτι με netstat (πέραν της αρχικής μου παρατήρησης) φαινόταν να ακούει τοπικά κανονικά - εκανε resolve τον εαυτο του και επαιζαν τα πάντα.
Εστίασα την προσοχή μου σε δυσλειτουργία του firewall και των accompanying services με αυτο.
Εκανα reset το stack - το Ipv4/ipv6 - εσβησα την καρτα και την ξαναδημιουργησα αλλα τίποτε.
Παρεπιπτόντος τον οδηγό που μου προτείνεις τον ακολούθησα στην αρχή της πορειας προς την λύση του προβλήματος. Σε ευχαριστώ.

Επιπρόσθετα το sfc /scannow δεν διεπίστωσε κανένα πρόβλημα -ούτε και οι wizards για resolution προβλήματος δυκτίου.
Μετά αποφάσισα να κάνω ένα system rollback 15 ημέρες πισω μπάς και το σώσω. Εκεί διεπίστωσα οτι απλά δεν το έκανε.

Τελικά το ξαναέστησα και όλα λειτουργούν κανονικά.
Ακόμη και τώρα δεν μπορώ να βρώ μια ικονοποιητική εξήγηση για το πως ενα μηχανημα με antivirus - 25 ημερών και αποδεδειγμενης προσεκτικής λειτουργίας απο τους 
χρήστες του έγινε τόσο χάλια.Το μόνο που μου έρχεται στο μυαλό είναι το απόφθεγμα του terminator(s..... happens)[:D]

Και παλι να ευχαριστησω ολους που δωσατε απο τον χρονο και τις γνωσεις σας.
Μέχρι το επόμενο πρόβλημα......

Share this post


Link to post
Share on other sites

Ok αλλά δεν μπορούμε να καταλήξουμε στο συμπερασμα ότι έφταιγε το tcp/ip .

To ότι από μέσα προς τα έξω έκανε πχ. ping και netstat και είχε επικοινωνία σημαίνει ότι το TCP/IP δούλευε.

Καποιο misconfiguration ήταν στο firewall/antivirus  αν όλες οι διαδικασίες με την SQL Express για τα ports  ήταν ok.

Βέβαια σε όλο το thread δεν το ανέφερες ότι το μηχάνημα δεν έβλεπε κάτι μεσα ή εξω αναφέρεις ΜΟΝΟ ότι απλά δεν βλέπει το 1433 του SQL .

Διαφωνω βέβαια με την εύκολη λύση του Format αν ήταν δηλαδή παραγωγικός server με x υπηρεσίες θα τον έκανες Format ?

Ο Server λειτουργούσε μέχρι που έβαλες τον SQL Express. Για να συνδεθείς τώρα από remote στον Express αυτό θέλει κάποια διαδικασία

που πρέπει να κάνεις και την έδωσα.

Αρα πιστεύω ότι ήταν θέμα misconfiguration και μπορούσαμε να το κάνουμε troubleshooting.

Θα το ξαναπω μέχρι να εμπεδωθεί το Format ειναι εχθρός του Troubleeshooting.

Κανένα Support Μicrosoft ή μη δεν θα σου πεις άμεσα να κάνεις Format.

Kαι στα Windows OΛΑ τα Services με τις απαραίτητες διαδικασίες μπορούν να γίνουν repair / recover ΧΩΡΙΣ Format.

Tωρα θα μου πείτε ο Χρονος ο Μanager με πιέζει ... αλλά με το Format απλά δεν μαθαίνεις και εσυ τι είχε και δεν μαζεύεις εμπειρία από περιπτώσεις .

 

Share this post


Link to post
Share on other sites

Αγαπητε skok - να μου επιτρέψεις να εχω την αποψη μου σαν τεχνικος πανω απο 15 χρονια - τα περισσοτερα απο αυτα σε περιβαλλον windows.

Αν και είμαι και εγω της αποψης οτι πρέπει να προσπαθούμε να λύνουμε τα προβλήματα - η  πειρα μου εχει δειξει οτι ειναι προτιμοτερο να κανω format παρα να φαω χρονο για αποσφαλματωση.

Δεν ξέρω εαν είσαι στην παροχή υπηρεσίας ή στις συμβουλετυικές υπηρεσίες (χωρίς να θέλω να σε προσβάλω) αλλά ίσως εγώ σε αντίθεση με εσένα δεν έχω την
πολυτέλεια να αποσφαλματώνω - ανεξερτήτως υπαιτιότητας.Ακόμη ακόμη μπορεί να μην έχω και τόσες γνώσεις όπως εσύ και κάποιοι άλλοι εδω.

Εαν όντος ήταν παραγωγικός server φυσικά και θα έκανα format διότι πολύ απλά δεν θα έπρεπε να χάσω αλλο χρόνο πέρα απο αυτόν που εγώ 
θεωρώ απαραίτητο για την δουλειά μου και φυσικά την δουλειά του πελάτη μου.

Στο συγκεκριμένο μηχάνημα έφαγα 4 ώρες με τις διαδικάσίες που ανέφερα και δεν δώθηκε αποτέλεσμα.

Και βέβαια μην τρελαθούμε κιόλας.
Τα windows δεν είναι και ότι καλύτερο.Το ξέρουμε όλοι μας.

Υπάρχουν φορές που δεν χρειάζεται να προσπαθήσουμε να γίνουμε καλύτεροι.Απλά χρειάζεται να δώσουμε μια όσον το δυνατόν πιο γρήγορη και άμεση λύση.
Αυτή θεώρησα ότι ήταν μια απο αυτές τις σπάνιες φορές.

Και πάλι ευχαριστώ όλους.
  

Share this post


Link to post
Share on other sites

nextp Στο παραπάνω post μου που αναφέρω για το Format ( Format ... No More !!! ) και στο ποιο πάνω http://autoexec.gr/forums/permalink/38742/38705/ShowThread.aspx#38705 


ΔΕΝ  αναφερόμουν προσωπικά σε εσένα αλλά ήθελα να δώσω μια διαφορετική προσέγγιση για περιπτώσεις αντιμετώπισης προβλημάτων.


Oπότε η συζήτηση είναι γενική και συνιστω ΨΥΧΡΑΙΜΙΑ !!!


Δεν ήθελα να θίξω κανέναν και φυσικα όχι εσένα δε αναφερόμουν προσωπικά . [:)]


Δηλαδή θέλω να πω ότι το Format δεν αποτελεί αποδεκτή λύση Troubleshooting και το έχω αναφέρει και σε άλλα post μου παλιότερα.


Αλλιώς κανείς δεν θα έγραφε χιλιάδες σελίδες σε βιβλία με Debugging και Troubleshooting μεθοδολογίες.


Θα σου έλεγε σε 2 λέξεις Problem Solution : Format - Re-Install.


Και επίσης δεν θα ήθελα κάποιος που θα διαβάσει αυτό το thread να μείνει με την εντύπωση ότι η λύση του προβλήματος σου είναι το FORMAT.


Σε ISP , τράπεζες που το Downtime δεν υπάρχει ως έννοια δηλαδή έχουν αδιαβλητη λειτουργία στις υπηρεσίες τους, αν πχ ένας παραγωγικός Server με X υπηρεσίες έχει πρόβλημα με ένα Component και τους πει κάποιος να κανουν Format στο Server για να επιλύσουν το πρόβλημα δεν νομίζω να έχουν την ίδια γνώμη.


Γιατί ακόμη και τα reboot γινόνται προγραμματισμένα βράδυ ή ξημερώματα για να μην είναι εμφανές το Downtime ( του reboot ... ) σε τράπεζες και ISP.


Ενας Senior Escalation Systems Engineer της Microsoft ή αλλού που κάνει Support σε Escalated Issues  έχει φάει άπειρες ώρες σε επίλυση προβλημάτων , είναι καλός με διάφορες μεθοδολογίες επίλυσης προβλημάτων troubleshooting σε Windows Server.


Αλλά σου δίνει γρήγορα λύση σε ένα πρόβλημα γιατί το έχει δει πολλές φορές εχει πείρα.


Την πρώτη φορά που αντιμετώπισε το πρόβλημα μπορεί να του πήρε 1 μερα την επόμενη 1 ωρα και τώρα το λύνει σε 5 min.


Είπες και κάτι άλλο που δεν συμφωνώ


"Και βέβαια μην τρελαθούμε κιόλας.

Τα windows δεν είναι και ότι καλύτερο.Το ξέρουμε όλοι μας."

 

Δεν έχω την ίδια άποψη και δεν "το ξέρουμε ολοι" .

Αρα μην γενικεύεις.

Ειναι προσωπική άποψη σου.

Κάποιοι μπορεί να διαφωνούν και να έχουν άλλη άποψη από εσένα.

 

Σε περιμένω στο επόμενο autoexec.gr event να τα πούμε και από κοντα για όλα τα παραπάνω μήπως και σου αλλάξω γνώμη για τα Windows ... [:)] [:)]

 

 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...