Jump to content
Sign in to follow this  
Blackman

metasploit on os x ... no minitest-4.7.5 and no Gemfile or .bundle/ directory

Recommended Posts

Blackmans-MacBook-Pro:/ blackman$ msfconsole
Could not find minitest-4.7.5 in any of the sources
Run `bundle install` to install missing gems.
Blackmans-MacBook-Pro:/ blackman$ bundle install
Could not locate Gemfile or .bundle/ directory

κάτι έκανα brick...
όλα έπαιζαν σωστά μεχρί που έκανα αυτό
 

sudo chmod o+r /Library/Ruby/Gems/2.0.0/gems/robots-0.10.1/lib/robots.rbτο οποίο με ταλαιπώρησε γιατί δεν έβρισκε κάν το robots*αλλά το έλυσα.μετά πήγα να τρέξω το msfconsole και έγινε το παραπάνω.το directory υπάρχει. πιστεύω ότι κάτι έχει παίξει με τα paths!το κεφάλι μου έχει γίνει καζάνι! οπότε...any ideas;;;;;

post-9484-0-92898600-1444850822_thumb.png

Share this post


Link to post
Share on other sites

ευχαριστώ παίδες...

ήμουν σίγουρος ότι είναι κάτι με τα paths...
από εκεί τσεκάρωντας μεσα από το irb
έλυσα και το θέμα του robots

αλλά θα τα δοκιμάσω και θα το δω!

Share this post


Link to post
Share on other sites

Blackmans-MacBook-Pro:~ blackman$ rvm gemset use metasploit-framework
Warning! PATH is not properly set up, '/Users/blackman/.rvm/gems/ruby-2.1.7/bin' is not available,
usually this is caused by shell initialization files - check them for 'PATH=...' entries,
it might also help to re-add RVM to your dotfiles: 'rvm get stable --auto-dotfiles',
to fix temporarily in this shell session run: 'rvm use ruby-2.1.7'.
Gemset 'metasploit-framework' does not exist, 'rvm ruby-2.1.7 do rvm gemset create metasploit-framework' first, or append '--create'.

-----------

Blackmans-MacBook-Pro:~ blackman$ rvm use ruby-2.1.7
Using /Users/blackman/.rvm/gems/ruby-2.1.7
Blackmans-MacBook-Pro:~ blackman$ msfconsole
/Users/blackman/.rvm/rubies/ruby-2.1.7/lib/ruby/site_ruby/2.1.0/rubygems/dependency.rb:315:in `to_specs': Could not find 'metasploit-framework' (>= 0) among 95 total gem(s) (Gem::LoadError)
Checked in 'GEM_PATH=/Users/blackman/.rvm/gems/ruby-2.1.7:/Users/blackman/.rvm/gems/ruby-2.1.7@global', execute `gem env` for more information
    from /Users/blackman/.rvm/rubies/ruby-2.1.7/lib/ruby/site_ruby/2.1.0/rubygems/dependency.rb:324:in `to_spec'
    from /Users/blackman/.rvm/rubies/ruby-2.1.7/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:64:in `gem'
    from /Users/blackman/.rvm/gems/ruby-2.1.7/bin/msfconsole:22:in `<main>'
    from /Users/blackman/.rvm/gems/ruby-2.1.7/bin/ruby_executable_hooks:15:in `eval'
    from /Users/blackman/.rvm/gems/ruby-2.1.7/bin/ruby_executable_hooks:15:in `<main>'



γαμώ τα paths μου...

Share this post


Link to post
Share on other sites

λέω να τα κάνω όλα από την αρχή! λέτε να βοηθήσει;;;

ή πρέπει να ασχοληθώ συγκεκριμένα με τα paths!

το μοναδικό που έκανα με Paths πάντως ήταν να τρέξω το irb για να φτιάξω το θέμα με το robots.rb αλλά δεν άλλαξα κάτι!

Share this post


Link to post
Share on other sites

μέσα από τον κατάλογο του metasploit και εφόσον έτρεξα

gem install bundler
bundle install

έπαιξε...

αλλά μου τρέχει ΜΟΝΟ μέσα από τον κατάλογο του metasploit

θυμίστε μου πως δηλώνω το path για να είναι global;

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...