Jump to content

Πρόβλημα με Cisco 2600 router και δικτύωση


Recommended Posts

Καλησπέρα,

 

Δεν βρήκα κάποιο networking section και το έβαλα εδώ. Ας μετακινηθεί στο σωστό, όποτε είναι δυνατόν.

Θα ήθελα τη βοήθεια σας για ένα πρόβλημα που αντιμετωπίζω σε μια εγκατάσταση:

 

Το setup έχει ως εξής:

  • Ένα switch 10/100 με 20 users και 5 devices (printers κλπ).
  • Ένα gigabit switch με 15 users και 3 devices
  • Ένα router Cisco 2600 που δημιουργεί ένα VPN με LAN IP έστω 1.1 και το οποίο είναι συνδεδεμένο πάνω στο gigabit switch
  • Ένα δεύτερο router που δίνει το Internet με LAN IP 1.2 και το οποίο είναι συνδεδεμένο στο 10/100 switch.
  • Τα δύο switch συνδέονται μεταξύ τους με ένα καλώδιο UTP.

 

Το setup δεν είναι σωστό καθόλου, συμφωνούμε προφανώς αλλά έτσι το βρήκα.

Υπάρχει το εξής πρόβλημα:
Σε κάποιες στιγμές μέσα στην ημέρα πέφτει το VPN (το internet λειτουργεί κανονικά). Επίσης, κάποιες άλλες πέφτουν όλα και επανέρχονται μόνο με restart του gigabit switch. Οι χρήστες έχουν μάθει λοιπόν και όταν δεν έχουν κάπου πρόσβαση, κάνουν restart το gigabit switch :)

 

Αφού (τουλάχιστον αρχικά) μου ανέφεραν ότι κολάει μόνο το VPN ρύθμισα το Cisco να στέλνει τα logs σε ένα syslog server και εμφανίστηκαν τα παρακάτω:

post-18227-0-63337700-1435602736_thumb.png

Σε αυτή τη φάση είχε πέσει όλο το δίκτυο και επανήλθε με restart του switch.

show interface ethernet και show controller ethernet.

post-18227-0-67039100-1435602734_thumb.png

 

Τα excessive collisions από ότι κατάλαβα δηλώνουν σημαντικό πρόβλημα στο δίκτυο, κάτι που προφανώς προκαλεί και την κατάρρευση του ανά διαστήματα.

 

Το θέμα είναι πώς το εντοπίζω.

Είναι πρόβλημα στην ethernet του Cisco; Είναι πρόβλημα των καλώδιωσεων και του γεγονότος ότι συνδέονται τα switch με ένα καλώδιο;

 

Κάθε βοήθεια ευπρόσδεκτη

Ευχαριστώ εκ των προτέρων

 

 

Link to post
Share on other sites

Δε νομίζω να είναι πρόβλημα ότι συνδέονται τα switch μόνο με ένα καλώδιο. Το πολύ πολύ η ταχύτητα μεταξύ των χρηστών ανάμεσα στα 2 switch να είναι αργή.

Το θέμα είναι οτι μάλλον πας για switch.

Επίσης με το VPN στο log πχ έχει πέσει 1 φορά αλλά η πόρτα στο switch έχει αρκετά θεματάκια.

Link to post
Share on other sites

Καλησπέρα,

 

Ευχαριστώ για την απάντηση.

 

Το δεύτερο sc είναι από το cisco router.

Το gigabit switch έχει αλλαχθεί με νέο και τα αποτελέσματα είναι τα ίδια.

Επίσης, σήμερα παρατήρησα το εξής: Όπως αναφέρω και στο πρώτο post ανάμεσα στο cisco router και στο 10/100 switch παρεμβάλεται το gigabit switch.

Έδωσα στο cisco router show cdp neighbors και μου επιστρέφει το 10/100 switch και σε ποια πόρτα είναι συνδεδεμένο το router. Με παραξενεύει γιατί παρεμβάλεται το gigabit switch. To cisco το παρακάμπτει και βλέπει απέναντι;

 

Αυτά τα collisions που βλέπω στο cisco router δεν είναι πιθανό να δηλώνουν πρόβλημα στο interface του;

Link to post
Share on other sites

Καλησπέρα,

 

Ένα πολύ πρόχειρο σχέδιο είναι αυτό:

post-18227-0-37809300-1436021700_thumb.png

Στο πλαίσιο των δοκιμών που κάνω, άλλαξα πόρτα στο 10/100 switch του καλωδίου που ενώνει τα δύο switches. Ενώ πριν το 10/100 switch μου έδινε πολλά collisions και μετά από λίγο  "lost link with multiple devices" στην πόρτα που οδηγεί στο απέναντι switch, με την αλλαγή τα collisions εξαφανίστηκαν και βλέπω μόνο "lost link with multiple devices" ανά διαστήματα μέσα στην ημέρα.

 

Δεν άλλαξε κατι προφανώς, το πρόβλημα παραμένει.

Link to post
Share on other sites

Καλησπέρα,

 

Ένα πολύ πρόχειρο σχέδιο είναι αυτό:

attachicon.gifnetwork.png

Στο πλαίσιο των δοκιμών που κάνω, άλλαξα πόρτα στο 10/100 switch του καλωδίου που ενώνει τα δύο switches. Ενώ πριν το 10/100 switch μου έδινε πολλά collisions και μετά από λίγο  "lost link with multiple devices" στην πόρτα που οδηγεί στο απέναντι switch, με την αλλαγή τα collisions εξαφανίστηκαν και βλέπω μόνο "lost link with multiple devices" ανά διαστήματα μέσα στην ημέρα.

 

Δεν άλλαξε κατι προφανώς, το πρόβλημα παραμένει.

 

Εχεις αποκλεισει το καλωδιο?

 

 

ΝΚ

Link to post
Share on other sites

Ξεκινώντας, θα πρέπει να αναφέρω οτι ο Cisco Router 2600 που διαθέτει το δίκτυο σου, είναι εξαιρετικά παλιός και δεν θα μου έκανε καμία απολύτως εντύπωση το οποιοδήποτε πρόβλημα παρουσιάζει ή θα παρουσιάσει.

 

Παρόλα αυτά, φαίνεται πως παρουσιάζεται και πρόβλημα στην γενικότερη διαμεταγωγή στο δίκτυο σου. Μιά απλοποίηση στην σχεδίαση νομίζω οτι είναι περισσότερο από απαραίτητη και αναγκαία, για να μπορέσεις να βγάλεις άκρη, όχι μόνο σήμερα αλλά και στο μέλλον.

 

Ετσι νομίζω, πως πρέπει να καταργηθεί ο Internet Router και όλο το Routing να γίνεται από έναν Router (Cisco or something else).

Link to post
Share on other sites

Εχεις αποκλεισει το καλωδιο?

Ναι Νίκο, το καλώδιο είναι σίγουρα ok.

 

Παρόλα αυτά, φαίνεται πως παρουσιάζεται και πρόβλημα στην γενικότερη διαμεταγωγή στο δίκτυο σου. Μιά απλοποίηση στην σχεδίαση νομίζω οτι είναι περισσότερο από απαραίτητη και αναγκαία, για να μπορέσεις να βγάλεις άκρη, όχι μόνο σήμερα αλλά και στο μέλλον.

Ετσι νομίζω, πως πρέπει να καταργηθεί ο Internet Router και όλο το Routing να γίνεται από έναν Router (Cisco or something else).

Βαγγέλη συμφωνώ απόλυτα μαζί σου (το ανέφερα ούτως ή άλλως και στο πρώτο μου post).

Αλλά τέτοιου είδους αλλαγές δεν είναι δυνατόν να γίνουν τουλάχιστον για την ώρα, γι'αυτό και ψάχνω μια λύση με τα υπάρχοντα δεδομένα.

 

Θα δοκιμάσω να βγάλω εκτός το cisco από την εξίσωση, να δω πώς θα συμπεριφερθεί το δίκτυο.

Τα logs πώς τα βλέπετε; Έχω διαβάσει documentation και δεν εντοπίζω κάτι συγκεκριμένο.

 

Μήπως σας έρθει καμιά διαίσθηση :)

Link to post
Share on other sites

Καλημέρα Γιάννη,

 

Είναι στις επόμενες κινήσεις. Θα το είχα κάνει ήδη αλλά δεν το επιτρέπει ο χώρος εκεί για την ώρα.

Σήμερα βλέπω και αυτά στο Cisco:

 

post-18227-0-44852400-1436425139_thumb.png

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

Καλησπέρα,

 

Δεν έχω επανέλθει καθώς αναμένονται εργασίες καλωδιώσεων.

Μπορεις να τσεκαρεις τα duplex settings στο Cisco?

Έχει έκδοση 11.3 και δεν μου δίνει επιλογές για duplex settings. Έχω ενημερώσει ότι πρέπει να γίνουν αναβαθμίσεις αλλά κινούνται λίγο αργά τα πράγματα.

 

Εν αναμονή

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...