Jump to content
Sign in to follow this  
Hary Dee

Συνδέομαι μόνο με καρφωτές IP & DNS. Γιατί;

Recommended Posts

Καλησπέρα. Πριν μήνες ξαφνικά δεν μπορούσα να συνδεθώ στο WiFi και αναγκαστικά έβαλα καρφωτή IP και DNS. Από τότε μόνο έτσι μπαίνω στο σπιτικό δίκτυο (Forthnet). Τι μπορώ να κάνω γι' αυτό;

Ευχαριστώ

Share this post


Link to post
Share on other sites

Τρέξε ξανά το setup wizard του router. Θα διορθώσει τα θέματά σου χωρίς κόπο.

Γιάννη άλλαξα ολόκληρο το router (για άλλο λόγο) αλλά δεν διορθώθηκε το πρόβλημα, έγινε χειρότερο*. Αλλά πέραν τούτου, αυτό το πρόβλημα το έχω μόνο εγώ στο δίκτυο, υπάρχουν και άλλοι "ασύρματοι" και μη, που δεν αντιμετωπίζουν κάτι τέτοιο.

 

 

* Χειρότερο γιατί αυτό έχει προεπιλεγμένη πύλη 192.168.1.254 και τα Windows όλο το ξεχνάνε, παρόλο που το βάζω καρφωτά. Δηλαδή πηγαίνω και το βλέπω κενό το πεδίο. Με το παλιό ρούτερ που η πύλη ήταν 192.168.1.1 το θυμόταν...

Share this post


Link to post
Share on other sites

Το μόνο που καταλαβαίνω είναι ότι έχεις κάποιο software το οποίο αποθηκεύει τα δικτυακά προφίλ με τις ρυθμίσεις τους πακέτο για να σε διευκολύνει να μην αλλάζεις με το χέρι ρυθμίσεις όποτε πηγαίνεις σε άλλο δίκτυο. Έτσι κάποια στιγμή αποθήκευσες το προφίλ του οικιακού σου δικτύου με λάθος ρυθμίσεις. Ενώ λοιπόν τις αλλάζεις με το χέρι, μόλις συνδεθείς στο δίκτυο το software που λέγαμε έρχεται και "φιξάρει" αυτές που είχε αποθηκευμένες.

Ψάξε για το software αυτό και ρύθμισέ το σωστά ή απενεργοποίησέ το. Είναι το μόνο που μπορώ να σκεφτώ.

Κοίτα να ελέγξεις μήπως σου έχει ξεφύγει και καμία άλλη συσκευή στο δίκτυο που παριστάνει τον DHCP Server.

Share this post


Link to post
Share on other sites

Τρέξε ξανά το setup wizard του router. Θα διορθώσει τα θέματά σου χωρίς κόπο.

Γιάννη άλλαξα ολόκληρο το router (για άλλο λόγο) αλλά δεν διορθώθηκε το πρόβλημα, έγινε χειρότερο*. Αλλά πέραν τούτου, αυτό το πρόβλημα το έχω μόνο εγώ στο δίκτυο, υπάρχουν και άλλοι "ασύρματοι" και μη, που δεν αντιμετωπίζουν κάτι τέτοιο.

 

 

* Χειρότερο γιατί αυτό έχει προεπιλεγμένη πύλη 192.168.1.254 και τα Windows όλο το ξεχνάνε, παρόλο που το βάζω καρφωτά. Δηλαδή πηγαίνω και το βλέπω κενό το πεδίο. Με το παλιό ρούτερ που η πύλη ήταν 192.168.1.1 το θυμόταν...

Εμένα αυτό που μοιάζει σαν να έχεις 2 interface που ταυτόχρονα είναι συνδεδεμέα στο router (σε αυτόν ή σε άλλον) και για αυτό μόνο ένα απο τα δύο κρατάει def.gateway,

Share this post


Link to post
Share on other sites

Έλεγξε πρώτα τα παραπάνω που πρότειναν οι συνάδελφοι και αν δε βρεις άκρη και ξέρεις πως να διαγράψεις την κάρτα δικτύου σου μαζί με τα drivers και κατόπιν να την ξαναβάλεις, κάντο. Αν έχεις πάλι πρόβλημα θα σου έλεγα να αλλάξεις κάρτα δικτύου.

Share this post


Link to post
Share on other sites

Γιάννη δεν έχω κάτι τέτοιο, τα αντιπαθώ ιδιαιτέρως. Ούτε έχω κανένα περίεργο antivirus που να τα κάνει μπάχαλο (έχω avira).

Θανάση εννοείς να έχω 2 ιστορίες πάνω στο pc μου; Δεν μου έρχεται κάτι σχετικό εκτός από το VirtualPC που έχω για τα XP. Μπορεί να φταίει κάτι τέτοιο ή μιλάς για κάτι άλλο;
Υπ' όψιν, δεν είμαι πληροφορικάριος για να τα πιάνω όλα εύκολα!

Share this post


Link to post
Share on other sites

MCP λες να έχει αποτέλεσμα αυτό με την επανεγκατάσταση των driver; Δεν μου είναι δύσκολο να το δοκιμάσω απλά τα αποφεύγω τα πολλά-πολλά με τους drivers![:D]

Share this post


Link to post
Share on other sites

Αν δεν έχει πρόβλημα η κάρτα σου τότε θα έχει αποτέλεσμα. Φρόντισε να διαγράψεις και τα drivers. Παίζει να σου γίνει καλά για λίγες μέρες και να σου χαλάσει πάλι κάτι που θα σημαίνει ότι θα πρέπει να αλλάξεις κάρτα.

Share this post


Link to post
Share on other sites

Παιδιά καλημέρα. Έκανα ένα search στη registry με τα 192.168.1.254 (router) και 192.168.1.103 (IP μου) και βρήκα 3 κλειδιά για το πρώτο και 2 για το δεύτερο. Μήπως κάπου εκεί πρέπει να κοιτάξω για τίποτε ρυθμίσεις, τιμές που χάλασαν κλπ; Μήπως κάπου εκεί μπορώ να καταλάβω για το διπλό interface που έλεγες Θανάση;

Συγκεκριμένα βρήκα στα εξής σημεία:

192.168.1.254
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\Tcpip\Parameters\Interfaces\{C188D68E-7811-4468-A9E4-9ED3BD373B1A}\B61647562796E616
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters\Interfaces\{C188D68E-7811-4468-A9E4-9ED3BD373B1A}\B61647562796E616
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\{C188D68E-7811-4468-A9E4-9ED3BD373B1A}\B61647562796E616

192.168.1.103
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\Tcpip\Parameters\Interfaces\{C188D68E-7811-4468-A9E4-9ED3BD373B1A}
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\{C188D68E-7811-4468-A9E4-9ED3BD373B1A}

Share this post


Link to post
Share on other sites

καλημέρα

Αντί να πειράξεις χειροκίνητα το registry δοκίμασε να τρέξεις αυτό το εργαλείο της MS που διορθώνει τυχόν λάθη στο TCP/IP.
Υπόψιν ότι θα γυρίσει τις ρυθμίσεις όλων των καρτών δικτύου σου σε DHCP mode.

Share this post


Link to post
Share on other sites
καλημέρα

Αντί να πειράξεις χειροκίνητα το registry δοκίμασε να τρέξεις αυτό το εργαλείο της MS που διορθώνει τυχόν λάθη στο TCP/IP.
Υπόψιν ότι θα γυρίσει τις ρυθμίσεις όλων των καρτών δικτύου σου σε DHCP mode.

Δεν δούλεψε. Τώρα το αν γύρισα την κάρτα σε DHCP mode δεν είμαι σίγουρος. Δηλαδή παίρνω και πάλι λάθος IP (κλάσης Β - 168...). Και η καρτέλα με τις εναλλακτικές IP δεν βοήθησε καθόλου. :(

Το ξέρω ότι ίσως πρέπει να γράψω πιο αναλυτικά τα αποτελέσματα αλλά λόγω καλοκαιριού το ίντερνετ σπανίζει :P ...

Share this post


Link to post
Share on other sites

η IP που πέρνεις δεν είναι λάθος...είναι η επονομαζόμενη APIPA (Automatic Private IP Addressing) και σου δίνει διευθύνσεις μεταξύ 169.254.0.1 μέχρι 169.254.255.254 το ίδιο το σύστημα. αυτό σημαίνει ότι δεν μπορεί να λάβει IP από τον DHCP του router σου. Αυτό μπορεί να προέρχεται είτε από πρόβλημα στον DHCP του router ή κάπου κόβονται κάποια πακέτα. Υπάρχει περίπτωση να έχεις ενεργοποιήσει κάτι στο router τύπου firewall ή άλλο αντίστοιχο; (δεν ξέρω και τις επιλογές που έχει το router σου).

 

η πιο εύκολη προσπάθεια επίλυσης για να μην ζορίζεσε είναι να πάρεις ένα router με dhcp που λειτουργεί σίγουρα (πχ ενός φίλου σου) και να το συνδέσεις με τον υπολογιστή σου να δεις τι γίνεται. Αν πάρει IP τότε το πρόβλημα είναι στο router...αν δεν πάρει τότε στο PC. Για να το επαληθεύσεις φέρε το laptop κάποιου φίλου σου που ξέρεις ότι δουλεύει και σύνδεσε το με το router σου να δεις την συμπεριφορά του. Πιθανό με αυτά τα δύο να επιβεβαιώσεις από που προέρχετε το πρόβλημα αντί να κάνεις τυχαίες δοκιμές.

Share this post


Link to post
Share on other sites

Έστω και ετεροχρονισμένα, Blackman το πρόβλημα υπέθετα ότι είναι στο laptop μου γιατί οι άλλοι 2-3 υπολογιστές που ήταν στο δίκτυο δεν είχαν τέτοια θέματα. Οπότε μάλλον κάτι είχα ρημάξει... [*-)]

Τέλος πάντων, η επαναφορά σε παλαιότερο image έλυσε το πρόβλημα...

Σας ευχαριστώ όλους για τη βοήθεια! [:D]

Share this post


Link to post
Share on other sites

Επειδή πλέον το συναντώ και σε άλλα PC (εκτός του δικτύου μου) το πρόβλημα, θα ήθελα να το ψάξω λίγο ακόμη.

η IP που πέρνεις δεν είναι λάθος...είναι η επονομαζόμενη APIPA (Automatic Private IP Addressing) και σου δίνει διευθύνσεις μεταξύ 169.254.0.1 μέχρι 169.254.255.254 το ίδιο το σύστημα. αυτό σημαίνει ότι δεν μπορεί να λάβει IP από τον DHCP του router σου. Αυτό μπορεί να προέρχεται είτε από πρόβλημα στον DHCP του router ή κάπου κόβονται κάποια πακέτα. Υπάρχει περίπτωση να έχεις ενεργοποιήσει κάτι στο router τύπου firewall ή άλλο αντίστοιχο; (δεν ξέρω και τις επιλογές που έχει το router σου).

η πιο εύκολη προσπάθεια επίλυσης για να μην ζορίζεσε είναι να πάρεις ένα router με dhcp που λειτουργεί σίγουρα (πχ ενός φίλου σου) και να το συνδέσεις με τον υπολογιστή σου να δεις τι γίνεται. Αν πάρει IP τότε το πρόβλημα είναι στο router...αν δεν πάρει τότε στο PC. Για να το επαληθεύσεις φέρε το laptop κάποιου φίλου σου που ξέρεις ότι δουλεύει και σύνδεσε το με το router σου να δεις την συμπεριφορά του. Πιθανό με αυτά τα δύο να επιβεβαιώσεις από που προέρχετε το πρόβλημα αντί να κάνεις τυχαίες δοκιμές.

Χρήσιμες οι πληροφορίες σου! Οι δοκιμές έδειξαν ότι τα "άρρωστα μηχανήματα" παρουσίαζαν πρόβλημα σε οριμένα μόνο δίκτυα το καθένα. Δηλαδή φαίνεται ότι ούτε κάποια ρούτερ δημιουργούν πρόβλημα με όλους τους χρήστες τους αλλά ούτε και κάποια pc έχουν πρόβλημα με όλα τα router.

Άλλες προτάσεις;

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...