Jump to content
Sign in to follow this  
sotos11

Exchange toolbox

Recommended Posts

Παιδια καλημερα.  Σε exchange 2013, προσπαθω να στειλεω email απο ενα λογαρισμο σε αλλο και τα μηνυματα αποθηκευονται στα προχειρα. δε φτανουν στον παραληπτη. Προσπαθω να στειλω απο αλλο λογαριασμο π.χ. gmail, ο πραληπτης δεν παιρνει τιποτα, ενω σε μενα έρχεται ένα μήνυμα 451 4.7.0 Temporary server error. Please try again later. PRX4

Μπαινω στον exchange και ολα τα services λειτουργουν κανονικα αλλα δε μπορω να ανοιξω το toolbox. μου εμφανίζει σφάλμα

 

Unhandled Exception in Managed Code Snap-in

FX:{714FA079-DC14-470f-851C-B7EAAA4177C1}

Exception type: System.Runtime.Serialization.SerializationException

Exception stack trace:

   at Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Request request)
   at Microsoft.ManagementConsole.Executive.RequestStatus.BeginRequest(IMessageClient messageClient, RequestInfo requestInfo)
   at Microsoft.ManagementConsole.Executive.SnapInRequestOperation.ProcessRequest()
   at Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(SimpleOperationCallback callback)

 

Τα services του exchange εινα σε κατασταση running

Μπορειτε να με βοηθησετε;Στα owa και ecp μπαινω κανονικα.

Share this post


Link to post
Share on other sites

Ξεχασα να πω οτι οταν προσπαθω να ανοιξω το toolbox εμφανιζεται πρωτα αυτο το μηνυμα MMC has detected an error in a snap-in and will unload it. δεν εχω κανει προσφατα ενημερωσεις.

Share this post


Link to post
Share on other sites

Δες λίγο διαθέσιμο δίσκο που τρέχουν. Αν έχεις κάτω από 4gb λογικό να βγάζει θέμα.

 

Δες και αυτό 

 

τρέξε σε powershell

 

Get-ServerComponentState –id ServerName

 

αν είναι σε Draining Status τρέξε το παρακάτω.

 

Set-ServerComponentState -identity ServerName -Component HubTransport -State Active -Requester Maintenance

 

περαιτέρω κοίτα εδώ

http://thoughtsofanidlemind.com/2013/03/25/exchange-2013-dns-stuck-messages/

Share this post


Link to post
Share on other sites

απο χωρητικοτητες δισκων δεν εχω προβλημα. εχω καμια 300αρια GB στο καθε δισκο ελευθερα. το dns το βλεπει κανονικα, το εχω ηδη ελεγξει στο ecp (αλλωστε δεν εχω σφαλμα με schannel).

τις εντολες του powershell τις βρηκα σε ενα blog. ετρεξα την πρωτη σε powershell και μου εμφανισε μηνυμα λαθους. το εβαλα στο συνημμενο

 

 

 

post-19235-0-42291800-1444501011_thumb.png

Share this post


Link to post
Share on other sites

εν τω μεταξυ, στον event viewer έχουν εμφανιστει πολλα σφαλματα. Και αποτι βλεπω καποια απο αυτα προεκυψαν απο επανεκκινησεις υπηρεσιων. Ανεβαζω τα πιο προσφατα μηπως μπορει να κατανοηθει καλυτερα το προβλημα.

post-19235-0-51923900-1444505667_thumb.png

post-19235-0-32139300-1444505676_thumb.png

Share this post


Link to post
Share on other sites

Δεν φόρτωσες το module του Exchange

Είτε άνοιξε windows powershell και τρέξε το παρακάτω πρώτα.

 

Add-PSSnapin Microsoft.Exchange.Management.PowerShell.SnapIn

 

Είτε άνοιξε του exchange την console και τρέξτο κατευθείαν.

Get-ServerComponentState –id ServerName

Share this post


Link to post
Share on other sites

Σε powershell, φορτωσα το module και ετρεξα την εντολη. Μου λεει οτι δε βλεπει domain. Κανω ελεγχο και βλεπω οτι κατα τη διαρκεια της νυχτας εσβησε ο domain controller. Δυστυχως δουλευω απομακρυσμενα και δε μπορω να τον ανοιξω. Δοκιμασα να ανοιξω το exchange shell (μάλλον αυτό εννοείς όταν λες exchange console) και μου βγαζει πριν προλβω να τρεξω την εντολη οτι δε μπορει να συνδεθει με τον remote server γιατι η προσβαση δεν επιτρεπεται. Το σφαλμα το εμφανιζει 5 φορες. Εχει να κανει που ο dc δε λειτουργει;

Ανεβασα και την εικονα του σφαλματος.

post-19235-0-24252000-1444541830_thumb.png

Share this post


Link to post
Share on other sites

Αν δε δουλεύει ο DC πως θα βρείς δικαιώματα mailboxes σε ποιον χρήστη κλπ;

 

Έκλεισε ο DC?

iDrac ή iLΟ δεν έχεις;

Χωρίς DC σε domain δε παίζει τίποτα.

Εσύ πως κάνεις Login στο remote με local admin account?

Share this post


Link to post
Share on other sites

Ναι, εκλεισε ο DC. Κανω login με τα συνθηματικα του διαχειριστη του domain. Τωρα πηγα να μπω, βαζω τα συνθηματικα και δε μαφηνει, εμφανιζοντας το μηνυμα: there are currently no logon servers available to service the logon request. Προφανως λογω DC. Όταν τον ανοίξω λογικά το θέμα του login θα λυθεί.

Το iDrac δεν εχει να κανει με Dell; για τη δικη μου περιπτωση εννοεις το iLO. Όχι δεν έχω.

Share this post


Link to post
Share on other sites

εν τω μεταξυ τωρα, δε μπορω να μπω στις σελιδες εισοδου ουτε στο owa ουτε στο eac. Μου βγαζει σφαλμα στο owa και runtime error στο ecp

Share this post


Link to post
Share on other sites

Στην θέση σου θα πήγαινα εγώ επιτόπου (κι αν αυτό δεν είναι εφικτό) θα χρησιμοποιούσα κάποιον άλλον τεχνικό που θα μπορούσε να πάει εκεί ώστε:

Να σηκώσει τον Domain Server και μετά Exchange (both restart θα έλεγα & με αυτή την σειρά)... Mετά (συνήθως) όλα ισιώνουν σαν να μην τρέχει τίποτα (που στο εύχομαι!!).

 

btw... έχεις secondary DC?

Share this post


Link to post
Share on other sites

εχω κανονισει να παω το πρωι εκει. Σε πρωτη φαση θελω να δω τι εγινε με τον dc και δεν ειναι στο δικτυο και επειτα να δω τον exchange.

 

Δυστυχως δεν εχω secondary DC. Thiseas ευχαριστω για την ευχη!

Παντως fumantsu και Thiseas σας ευχαριστω για τις οδηγιες και τις συμβουλες.

Share this post


Link to post
Share on other sites

οντως ειχε σβησει ο dc. τον εκκινησα και εκανα επανεκκινηση τον email server. ετρεξα τις εντολες που προτεινε ο fumantsu

Add-PSSnapin Microsoft.Exchange.Management.PowerShell.SnapIn

Get-ServerComponentState –id ServerName

και μου εβγαλε τη λιστα αλλα ολα ειναι active. ανεβασα και screenshot.

 

Αφου ειναι active, εχει νοημα να τρεξω το Set-ServerComponentState -identity ServerName -Component HubTransport -State Active -Requester Maintenance  ;;;;

post-19235-0-81912300-1444633144_thumb.png

Share this post


Link to post
Share on other sites

Όχι λογικά τα e-mail σου τώρα δουλεύουν. Κάνε μια δοκιμή και αν έχεις θέμα το ξανακοιτάμε.

Σίγουρα δεν δούλευαν τα e-mail γιατί ο DC ήταν Off. Τώρα αν έχει και άλλο θέμα θέλει περαιτέρω έρευνα.

 

Βάλε και έναν 2ο DC για περίπτωση που πέσει ο πρώτος. Αν ο DC είναι κάτω δεν δουλεύει τίποτα σχεδόν.

Share this post


Link to post
Share on other sites

Σου βγάζει κάποιο error όταν πας να στείλεις; Με telnet δοκίμασες να συνδεθείς στον Server?

 

Και από το εσωτερικό δίκτυο αλλά και από εξωτερικό WAN.

 

telnet mail.server.gr 25

Share this post


Link to post
Share on other sites

Κάνε ένα restart το transport service μήπως το timing DC με Exchange στο boot ήταν λάθος και έχει κολλήσει και δεν επικοινωνούν.

Share this post


Link to post
Share on other sites

το εχω ηδη κανει. τιποτα. ετρεξα στο powershell και το Set-ServerComponentState -identity ServerName -Component HubTransport -State Active -Requester Maintenance. πηρε την εντολη αλλα τιποτα.

Share this post


Link to post
Share on other sites

η εντολη χρειαζεται επανεκκινηση μετα;

 

τον πατησα μια επανεκκινηση και μολις λειτουργησε τα emails αρχισαν να ερχονται και να φευγουν.

Share this post


Link to post
Share on other sites

Η εντολή απλά γυρνάει τα services από Draining σε Active.

Θεωρώ ότι με το restart επανήλθε η επικοινωνία με τον DC γιαυτό και δούλεψε.

Πάλι καλά που έληξε το θέμα προσωρινά. Αλλά να έχεις λίγο στον νού σου τι γίνεται μην το ξανακάνει.

 

Αν και ξαναλέω σίγουρα το πρόβλημα αρχικά ήταν ο κλειστός DC. Ειδικά αν τον έχεις και DNS.

Share this post


Link to post
Share on other sites

Συμφωνω, αλλα το θεμα ειναι πως με το που ξεκινησε το πρωι ο DC, εκανα και 2 επανεκκινησεις τον email server και δεν εγινε τιποτα. Στον event viewer δε φαινοταν να λεει οτι υπηρχε προβλημα επικοινωνιας π.χ. schannel, AD Topology, ADAccess (αν θυμαμαι καλα), ενω οσο ηταν κλειστος εμφανιζε συνεχεια αυτα τα μηνυματα.

Ο DC ειναι και DNS, οποτε ενισχυει την αποψη σου.

Εληξε το θεμα προσωρινα; sad.png

Παντως σε ευχαριστω πολυ για την υπομονη και το ενδιαφερον σου. οπως και τον Thiseas

Share this post


Link to post
Share on other sites

Επειδή δεν είμαι 100% σίγουρος ποιο ήταν το πρόβλημα δεν μπορώ να πω μόνιμα. Για να έχεις τον νου σου περισσότερο

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...