Jump to content
alex_agp

Exchange Send Connector MX or SmarHost

Recommended Posts

Γεια σας,

έχω μια απορία για το πως να φτιάξω τον Send Connector του Exchange 2016 on premise.

Αυτή τη στιγμή τα emails τα στέλνει κατευθείαν ο Exchange χωρίς να τα προωθεί σε SmartHost.

Η απορία αυτή δημιουργήθηκε γιατί ΔΕΝ έχω καλή γραμμή Internet και όταν στέλνω ένα email σε πολλούς recipients τότε στη queue του Exchange υπάρχουν κολλημένα πολλά emails, αν έχει και attachment τότε πάει...

 

Μπορώ με κάποιο τρόπο να φεύγει από εμένα ένα email (δηλ και ένα attachment) και μετα την δρομολόγηση να την κάνει κάποιος άλλος? σκέφτηκα μήπως αυτό γίνεται με το SmartHost?

 

Θα πρέπει να προσθέσω το SmartHost στο SPF?

 

ευχαριστώ,

Share this post


Link to post
Share on other sites

Ναι πρέπει να προσθέσεις τον SmartHost στο SPF Record. ΑΛΛΑ η λειτουργία θα είναι ίδια., Πρέπει να φύγει τόσες φορές και προς τον Smart Host. Αν βάλεις SmartHost θα δεις ότι στο Queue θα είναι προς τον Smart Host τόσες φορές όσες είναι οι παραλήπτες.

Πάντα θα φεύγει το Email από εσένα... Δεν υπάρχει τρόπος να το στείλεις μία φορά και αυτό να φύγει σε πολλούς... ΟΣΟ έχεις εσύ τον Mail Server αυτή είναι η συμπεριφορά.

Share this post


Link to post
Share on other sites

Ευχαριστώ Kostas Lagiopoulos ( klag )!!

Ήσουν κατατοπιστικοτατος! Επισης παρατηρώ οτι στο Queue βλεπω συχνα errors(πχ για DNS) αλλά μετα απο λιγό φευγουν κανονικα τα emails. Νομιζετε πως μπορει να φταει ισως καποιο delay λογω κακης ταχυτητας ιντερνετ?

Share this post


Link to post
Share on other sites

Ποιον DNS έχει δηλωμένο στην κάρτα δικτύου του ο Exchange? Λογικά πρέπει να έχει τον Domain Controller σου.
Ο DNS του Domain Controller σου τι Forwarders έχει ρυθμισμένους? Βάλε στον DNS του Domain Controller σου σαν πρώτο Forwarder τον 1.1.1.1 και σαν δεύτερο τον 8.8.8.8.

Με τον τρόπο αυτό θα αποφύγεις και διάφορα σφάλματα που τυχόν έχεις ή θα έχεις χρησιμοποιόντας κάποιους forwarders πχ της OTenet.
Επίσης πήγαινε στην σελίδα https://mxtoolbox.com/  
Βάλε το Domain σου
Πάτησε MX Lookup και θα σου φέρει το MX Record σου

Πάτησε το SMTP Test και δες τι Errors σου φέρνει. Κανονικά δεν θα πρέπει να έχεις κανένα Error εκεί ώστε να δουλέυει ποιο σωστά ο mail server σου. Αν έχεις Errors πρέπει να φροντίσεις να τα διορθώσεις.
Επίσης πάτησε και το BlackList Check. Αν σε βγάζει σε κάποια λίστα BlackListed θα πρέπει να φροντίσεις να κάνεις Delist την ΙΡ σου από αυτή την BlackList που σου λέει.

Στο SMTPCheck θα σου δείξει και τυχόν προβλήματα με την ταχύτητά σου (στο Incoming Mail σου βέβαια...)

Κανονικά για να σου βγάλει DNS Error στο Outgoing mail σου , λογικά δεν έχεις καθόλου Internet εκείνη την στιγμή , Οπότε θεωρώ ότι δεν είναι σφάλμα ταχύτητας. ή δεν έχεις καθόλου Internet ή κάτι έχεις στραβό στον DNS σου ίσως. Β.εβαι δεν μπορώ να αποκλείσω ότι ίσως λόγο πολύ πολύ μικρής ταχύτητας κάνει κάποιους λόξυγγες...

Επίσης κάνε και ένα test με το https://testconnectivity.microsoft.com/ 

Share this post


Link to post
Share on other sites

Ναι οπως το ειπες, ειχα τους DNS του OTE και βαζοντας 1.1.1.1 και 8.8.8.8 εχει φυγει το προβλημα. Τα checks απο το MXtools και Microsoft Analyzer ειναι ολα πρασινα. 

Μαλλον λογω χαμηλης ταχυτητας χανει κανα bit στην επικοινωνια και βγαζει τα errors.

Θα παει σε οπτικη ινα σε λιγο καιρο θα διορθωθει πιστευω.

 

σε ευχαριστω,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...