Jump to content
mts

WMI Filter για να αποκλείσουμε Windows 10 υπολογιστές?

Recommended Posts

Καλησπέρα,

 

Έχω ένα GPO το οποίο το έχω εφαρμόσει σε ένα συγκεκριμένο OU στο Active Directory. Πως μπορώ να φτιάξω ένα φίλτρο WMI ώστε να μην εφαρμόζεται σε υπολογιστές με λειτουργικό Windows 10?

 

Mήπως απλά πρέπει να βάλω ένα φίλτρο που να λέει πχ :

 

Root\CimV2; Select * from Win32_OperatingSystem where Caption = "Microsoft Windows XP Professional"

Root\CimV2; Select * from Win32_OperatingSystem where Caption = "Microsoft Windows 7"

Root\CimV2; Select * from Win32_OperatingSystem where Caption = "Microsoft Windows 8"

Root\CimV2; Select * from Win32_OperatingSystem where Caption = "Microsoft Windows 8.1"

 

 

...ώστε να εφαρμόζεται μόνο σε αυτούς τους υπολογιστές?

 

Σας ευχαριστώ εκ των προτέρων!

Share this post


Link to post
Share on other sites

Πιστευω πως μπορείς να το κάνεις με το Version πολύ πιο εύκολα, με select οτι μικρότερο του 10.

 

 

πχ. Root\CimV2; Select * from Win32_OperatingSystem where Version < 10

Share this post


Link to post
Share on other sites

έχω γράψει κάτι σχετικό για τα windows 10
έτσι και αλλιώς χρειάζεται wmi filter για να το δει σωστά ένα 10άρι το gpo για Homefolder πχ

http://autoexec.gr//index.php?/topic/6727-windows-10-my-documents-home-folders/

αλλά θέλει προσοχή! αυτό που έγραψε ο Μιχάλης πιθανότατα να μην παίξει... αν όχι ...τότε δοκίμασε να το γράψεις "10.%" (με αυτάκια)
γιατί το σύστημα αλλιώς θα το δει σαν version 1

δοκίμασε:
Root\CimV2; select * from Win32_OperatingSystem where not Version like "10.%" and ProductType = "1"

ή και χωρίς το ProductType

 

αυτά καταλαβα εγώ από την δική μου αναζήτηση!

όσο για το forum...έχει πέσει αρκετά!
αλλά είναι στο χέρι μας να το κρατήσουμε ζωντανό!

συνέχιζε να γράφεις εσύ...και όποιος αλλος...
τους υπολοιπους θα τους κράξω κατ'ιδίαν !

Share this post


Link to post
Share on other sites

βάλε ότι είναι μετά το WHERE ... σε παρένθεση

πχ
select * from Win32_OperatingSystem where (not Version like "10.%" and ProductType = "1")

Share this post


Link to post
Share on other sites

Λοιπόν.. 

 

Έχουμε 3 Domain Controllers (1 x 2008 R2, 1 x 2012 R2 και 1 x 2003 R2). Δοκίμασα να προσθέσω το WMI Filter από

 

  • Τον 2008 R2 Server
  • Τον 2012 R2 Server
  • το PC μου (με Windows 10 Pro 64bit) 

 

και στα τρία μου έβγαζε το Warning message που σας έδειξα στην εικόνα. 

 

Μόλις τώρα προσπάθησα να προσθέσω το WMI Filter από τον 2003 R2 Server και δεν μου έβγαλε κανένα warning.. 

 

το θέμα όμως είναι πως το φίλτρο δεν λειτουργεί.. 

 

κάνω συνέχεια gpupdate /force στον υπολογιστή μου (που είναι Windows 10 Pro) και το GPO δουλεύει κανονικά.. (ενώ θα έπρεπε να γίνει exclude στον υπολογιστή μου)..

 

:(

Share this post


Link to post
Share on other sites

Αν δε κάνω λάθος ο 2003 και εφόσον και το domain λογικά είναι σε 2003 δε βλέπει τα μηχανήματα σαν win 10 αλλά σαν vista.

Σίγουρα ο wsus τα βλέπει έτσι άρα υποθέτω και ο DC πρέπει.

Share this post


Link to post
Share on other sites

βασικά σε πρώτη φάση βγάλε το από το συγκεκριμένο GPO...
φτιάξε ένα νέο (αντίγραφο) και όρισε το σε ένα δοκιμαστικό OU και εκεί βάλε τα μηχανήματα που θες...

fumantsu...με ένα update τα βλέπει 10άρια κανονικά!
το πρόβλημα είναι ότι η version 10 την βλέπει σαν 1 στα group policies και θέλουμε το παραπάνω για να παίξει σωστά!

επειδή την πατησα και εγώ όταν το έφτιαχνα, για να δει windows 10 ουσιαστικά κάτι δεν έβαλα σωστά και μου το ακύρωσε τελείως το GPO καθώς και όλα τα exclusions ...οπότε θέλει να περαστεί σωστα

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...